Cryptocurrency Exchange Platform - Barong

Guide | API Docs | Consulting | Community

Component part of OpenDAX Trading Platform

Barong

Build Status Maintainability

Overview

Barong is oAuth server for [Openware.com][openware.com] stack.

Development

Prerequisites: - Ruby version: 2.5.3 - Bundler preinstalled - MySQL preinstalled

  1. Install RubyGems dependencies bundle install

  2. Copy initialisation files bin/init_config

  3. Create database and run migrations bundle exec rake db:create db:migrate

  4. Install JS dependencies yarn install

  5. Start local server bundle exec rails server

Barong Levels

In the process of verification Barong assign different levels to accounts

  • Level 0 is default account level
  • Level 1 will apply after email verification
  • Level 2 will apply after phone verification
  • Level 3 will apply after identity & document verification

Useful links to documentation

Barong environments overview

Barong configurations overview

Troubleshooting

REST API documentation

API Keys creation and usage

Captcha policy overview and configuration

Setting up 2FA

Barong password hashing

License

Barong is released under the terms of the Apache License 2.0.