coinbase-pro-trading-toolkit

DEPRECATED — The Coinbase Pro trading toolkit

coinbase/coinbase-pro-trading-toolkit
starsStars 811
forksForks 232
watchersWatchers 811
current-versionCurrent version v0.1.18
total-releasesTotal releases 5
open_issues_countOpen issues 0
dateFirst release 2017-08-31
dateLatest release 2017-10-06
updateLast update 2020-12-17

Coinbase Pro Trading toolkit

Note: The gdax-trading-toolkit package is deprecated and might have to be removed from NPM. Please migrate to the coinbase-pro-trading-toolkit package to ensure future compatibility.

Provide all the tools traders need, both professional and hobbyist alike, to create automated trading bots on the Coinbase Pro and supported digital asset exchanges. Note: Node 7.6 or above is required.

Recommended:

  • Node 9.4 or above
  • Typescript 2.7

Install

yarn add coinbase-pro-trading-toolkit

Test

Run the included test suite with the command

yarn test

Run

The src/samples folder contains many working demo scripts showcasing different aspects of the toolkit, while the tutorials folder contains running demo programs to accompany the CBPTT documentation.

Documentation

The CBPTT documentation contains blogs, reference material and step-by-step tutorials

Disclaimer

This software is provided "as is", without warranty of any kind, express or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and non-infringement. In no event shall the authors, copyright holders, or Coinbase Inc. be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with the software or the use or other dealings in the software.